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CHAPTER 1
Welcome to Macromedia FlashPaper
Macromedia FlashPaper 2 lets you easily convert any printable document (such as a Microsoft 
PowerPoint, Word, or Excel document) to a FlashPaper SWF file or a Portable Document Format 
(PDF) file. You can use a FlashPaper document when you need to share a file with users who don’t 
have the software that created the original document. You can view FlashPaper documents (in 
both SWF and PDF formats) on Windows and Macintosh systems.

The FlashPaper Printer (the software that creates FlashPaper documents) works on Macintosh OS 
10.2.6 and later, and on Microsoft Windows XP and Windows 2000 operating systems.

This chapter contains the following sections:

Activating FlashPaper

About FlashPaper documents

FlashPaper features

Using the FlashPaper toolbar

Activating FlashPaper

If you are a single-license user, you must activate FlashPaper within 30 days of installation. 
(Before activation, FlashPaper runs for 30 days in trial mode only.) You can activate the product 
through an Internet connection or by phone in a simple, seamless process that takes only a few 
moments. Product activation does not require you to submit personal information, but only your 
product serial number.
Note: Windows 98 SE users must have Microsoft Internet Explorer 5.1 or later to activate FlashPaper 
over the Internet.

To activate FlashPaper:

1. Double-click the FlashPaper executable icon, or select Programs > Macromedia > FlashPaper 
from the Windows Start menu.

2. Select the serial number radio button.

3. Click Continue to go to the next screen.

4. Enter your serial number in the Macromedia Product Activation window, and click Continue.

After activation, your product is ready to use.
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For more information on product activation, please visit www.macromedia.com/go/activation/.

It’s also a good idea to register your copy of FlashPaper electronically or by mail. Registration 
entitles you to additional Macromedia support.

When you register, you can sign up to receive up-to-the-minute notices about upgrades and new 
Macromedia products. You can also sign up for timely e-mail notices about product updates and 
new content appearing on www.macromedia.com.

To register FlashPaper:

• In FlashPaper, select Help and then select either the online or the print registration option.

About FlashPaper documents

FlashPaper lets you create SWF or PDF files from any type of printable document. You can 
view FlashPaper documents across platforms and retain the formatting, graphics, fonts, special 
characters, and colors of source documents, regardless of the application and platform used to 
create the document. For example, if you created a Microsoft Excel spreadsheet on a Windows XP 
computer, you can use FlashPaper to convert it to a SWF file, and then send it to a 
Macintosh user.

The SWF files that FlashPaper generates are in the same format as those generated by 
Macromedia Flash. FlashPaper SWF files are typically much smaller than other document types, 
and you can view them in any browser that supports Flash, or you can view them directly in 
Macromedia Flash Player. Because you can embed a FlashPaper SWF file in a web page, you can 
publish file types that most people can’t easily view on the web today, such as Microsoft Project, 
Microsoft Visio, and even QuarkXPress and AutoCAD. When a user opens your web page, the 
FlashPaper SWF file opens instantly, so that the user can view the file without leaving the 
web page.

FlashPaper documents (in both SWF and PDF formats) also work well as standalone files. 
Anyone who has FlashPlayer installed on their computer can view FlashPaper SWF files, and 
anyone who has Adobe Acrobat Reader installed on their computer can view PDF files.

FlashPaper features

When you create a FlashPaper document, you use the FlashPaper application. When you view a 
FlashPaper document, you use Flash Player or a web browser.

The FlashPaper application environment has the following key features:

Drag-and-drop FlashPaper SWF and PDF file creation You can convert printable 
documents to FlashPaper documents by dragging them directly to the FlashPaper application 
window.

E-mail PDF You can use FlashPaper to convert printable documents to PDF format and e-mail 
them in one quick step.

Microsoft Office add-in features FlashPaper installs menu items and toolbar buttons that let 
you generate FlashPaper documents directly from within Microsoft Word, PowerPoint, and Excel.
6 Chapter 1:  Welcome to Macromedia FlashPaper
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PDF security When you create a PDF file using FlashPaper, you can require a password to 
open the file. You can also prevent viewers from copying and editing the text of the file, altering 
the file’s graphics, and printing the file.

Right-click FlashPaper SWF and PDF file creation You can right-click documents on your 
desktop and print them directly to the FlashPaper Printer to create FlashPaper documents.

The viewing environment has the following key features:

Accessibility FlashPaper viewer toolbar buttons, controls, and scroll bars are accessible to users 
with disabilities. Additionally, screen readers can read regular and alternative text in FlashPaper 
documents in compliance with Section 508 of the American Disabilities Act.

Automatic hyperlinks FlashPaper documents automatically retain clickable links created in 
Microsoft Word, PowerPoint, and Excel documents.

Document outlines FlashPaper documents retain the structural and navigational elements 
created with headings in Microsoft Word and PowerPoint documents.

Resizing FlashPaper documents are resized proportionately, regardless of the size of the Flash 
Player or the browser window. You can easily resize a document by dragging a window, or by 
using the resize options in the toolbar.

Searching The search feature lets you search for a word or group of words in a FlashPaper 
document.

Text selection You can select text in a FlashPaper document, copy it to your Clipboard, and 
paste it into another document.

Using the FlashPaper toolbar

The FlashPaper toolbar contains options that let you resize a document for viewing, navigate 
through the document pages, select text, search the document, and print the document. The 
FlashPaper toolbar is the same in both the application and viewing environments.

Note: The File menu and Help menu are visible only in the application environment.

To print a document: 

• Click the Printer icon.

Print
Zoom

Scroll pages

Search
Pan

Select

Fit in Viewer

Fit Width

Page 
Navigation

Open in New 
Browser
Using the FlashPaper toolbar 7



To select text in the document:

1. Click the Select button.

2. Drag the pointer to select text in the document window.

You can Shift-click to select multiple words or lines of text.
3. Click the Pan button to return to viewing the document.

To search the document:

1. In the search text field, type words you want to search for, and then click the Search button. 

FlashPaper selects the first instance of the matching words.
2. To find the next instance of the matching words, click the Search button again.

Note: The search feature requires that you have Flash Player 7 installed on your computer. If you have 
Flash Player 6 or earlier, you cannot use the search feature.

To resize the document, do one of the following:

• Use the Zoom slider to dynamically resize the document.
You can adjust the document magnification range from 25% to 250%. The Zoom text box is 
updated as you use the slider.

• Enter a number in the Zoom text box to resize the document to a specific magnification.
• Click the Fit in Viewer button to see the entire page in the viewer.
• Click the Fit Width button to resize the document so that the width of the page fills 

the viewer.

To navigate or page through the document, do one of the following:

• Enter a number in the Page Navigation text box to view a specific page.
• Click the Previous arrow or the Next arrow to page backward or forward through a document.
• Drag the page scroll box, located to the right of the document, to scroll through multiple-page 

documents.

To open a document in a new browser window:

• Click the Open in New Browser button.

Note: The Open in New Browser button appears only in the FlashPaper viewing environment 
(saved SWF files).
8 Chapter 1:  Welcome to Macromedia FlashPaper



CHAPTER 2
Using FlashPaper to Convert Documents
You can use Macromedia FlashPaper to convert any printable document to a FlashPaper SWF file 
or a PDF file. This chapter provides general information about converting printable documents, 
as well as specific information that tells you how to use FlashPaper with individual Microsoft 
Office applications.

This chapter contains the following sections:

Converting documents with FlashPaper

Converting Microsoft Office documents

Converting documents with FlashPaper

You can convert a document to a FlashPaper document while working in any other application 
that produces printable documents (for example, Microsoft Word or Excel, or FrameMaker), or 
by using the FlashPaper application itself.

For more information on using FlashPaper with Microsoft Office applications, see Converting 
Microsoft Office documents.

To convert a document to a FlashPaper document while working in another application:

1. In the application that you are using to convert a document to a FlashPaper document, select 
File > Print.

2. For Printer Name, select Macromedia FlashPaper.

3. Set the printer options you want to apply to the converted document. For example, in some 
applications you can print a range of pages or the selected pages.

4. Click Properties if you want to specify the page orientation and page size of the FlashPaper 
document. 

5. Click OK.

The document is converted to a FlashPaper document and appears in the FlashPaper viewer.
6. Select File > Save as Macromedia Flash or File > Save as PDF to save the document in the 

desired location.
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Note: You cannot edit a FlashPaper document. If you need to update the document, you must make 
changes to the document you originally converted and then convert it again to a FlashPaper 
document.

To convert a document to a FlashPaper document by using the FlashPaper application:

1. Start FlashPaper by selecting the program icon from the Windows Start menu.

The FlashPaper viewer appears.
2. In Windows Explorer or on your desktop, find the document you want to convert; then drag 

its icon to the FlashPaper viewer.

FlashPaper converts the document and displays it in the FlashPaper viewer.
3. Select File > Save as Macromedia Flash (.swf) or File > Save as PDF to save the document in the 

desired location.

Converting Microsoft Office documents

FlashPaper integrates seamlessly with Microsoft Office applications by adding a FlashPaper menu 
and FlashPaper toolbar buttons to Microsoft Word, PowerPoint, and Excel. The FlashPaper 
toolbar buttons let you create FlashPaper documents with a single click.

To convert a document to a FlashPaper document using the FlashPaper toolbar buttons:

1. Open the document you want to convert.

2. Do one of the following:

■ Click the Convert current document to Macromedia Flash toolbar button to convert the 
document to a FlashPaper SWF file.

■ Click the Convert current document to PDF toolbar button to convert the document to a 
PDF file.

■ Click the Convert current document to PDF and e-mail it toolbar button to convert the 
document to a PDF file and e-mail it.

 FlashPaper toolbar buttons

FlashPaper menu
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To convert a document to a FlashPaper document using the FlashPaper menu:

1. Open the document you want to convert.

2. Do one of the following

■ Select FlashPaper > Convert to Macromedia Flash (.swf ) to convert the document to a 
FlashPaper SWF file.

■ Select FlashPaper > Convert to PDF to convert the document to a PDF file.
■ Select FlashPaper > Email PDF to convert the document to a PDF file and e-mail it.

To convert a document to a FlashPaper document by right-clicking:

1. Right-click the file you want to convert in Windows Explorer or on your desktop.

2. Select one of the following from the context menu:

■ Convert to Macromedia Flash (.swf ) to convert the document to a FlashPaper SWF file.
■ Convert to PDF to convert the document to a PDF file.
■ Convert to PDF and e-mail to convert the document to a PDF file and e-mail it. 
Converting Microsoft Office documents 11
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CHAPTER 3
Working with Microsoft Office Applications
This chapter contains information about features in Microsoft Office applications that integrate 
with Macromedia FlashPaper 2. When you convert Microsoft Office documents to FlashPaper 
documents, some elements, such as hyperlinks, document outlines, and accessible content, are 
automatically converted. If you are using FlashPaper to create a PDF file, you can also set PDF 
security options in the Microsoft Word FlashPaper Options dialog box.

This chapter contains the following sections:

Creating hyperlinks in FlashPaper documents

Creating document outlines in FlashPaper documents

Creating accessible content in FlashPaper documents

Selecting a Microsoft Excel print area to convert to a FlashPaper document

Using the FlashPaper Options dialog box

Creating hyperlinks in FlashPaper documents

When you convert a Microsoft Word, PowerPoint, or Excel document that already contains 
hyperlinks, FlashPaper preserves the hyperlinks for you.

To create a hyperlink in a FlashPaper document:

1. Create a hyperlink in the document that you want to convert. 

For example, you can create a hyperlink in a Microsoft Word 2002 document by selecting 
Insert > Hyperlink. For more information about creating hyperlinks, see the Microsoft Word, 
PowerPoint, or Excel help systems.

2. Select FlashPaper > Convert to Macromedia Flash (.swf).

3. Save the file in the desired location.
13



Creating document outlines in FlashPaper documents

When you convert a Microsoft Word or PowerPoint document that already contains an outline, 
FlashPaper preserves the outline for you. For Excel documents, FlashPaper creates an outline 
using the title of each spreadsheet tab.

To create a document outline in a FlashPaper document:

1. Create an outline in the Microsoft Office document you want to convert.

For example, you can create a Document Map in a Microsoft Word document by applying 
heading styles to lines of text in your document. The following figure shows a Microsoft Word 
2002 document that uses three levels of headings:

For more information about formatting headings in Microsoft Word, see the Microsoft Word 
help system.

2. Select FlashPaper > Convert to Macromedia Flash (.swf).

3. Save the file in the desired location.

Note: By default, FlashPaper documents retain outlines in Microsoft Word and PowerPoint 
documents. (For Excel documents, the title of each tab becomes a heading in the outline.) If your 
Microsoft Office document contains an outline and you want to create a FlashPaper document that 
does not contain an outline, select FlashPaper > Options and deselect Include Outline. For more 
information, see “Using the FlashPaper Options dialog box”.
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Creating accessible content in FlashPaper documents

When you convert a Microsoft Word, PowerPoint, or Excel document that already contains 
accessible content, FlashPaper preserves the accessible content for you.

To create accessible content in a FlashPaper document:

1. Create accessible content in the document you want to convert. 

For example, you can create accessible content in a Microsoft Word document by assigning 
alternative text to an image. The following figure shows a selected image in a Word document, 
with alternative text typed in the Alternative Text box.

For more information about creating alternative text, see the Microsoft Word, PowerPoint, or 
Excel help systems.

2. Select FlashPaper > Convert to Macromedia Flash (.swf).

3. Save the file in the desired location.
Creating accessible content in FlashPaper documents 15



Selecting a Microsoft Excel print area to convert to a 
FlashPaper document

You can select a print area in a Microsoft Excel document to convert to a FlashPaper document. 
For example, you can select specific rows and columns to convert to a FlashPaper document. You 
can also select multiple Excel worksheets and convert them to a FlashPaper document.

To select a FlashPaper print area in Microsoft Excel:

1. In the Microsoft Excel document, drag to select the part of the worksheet that you want to 
convert to a FlashPaper document. 

2. Select File > Print Area > Set Print Area.

3. Do one of the following

■ Select FlashPaper > Convert to Macromedia Flash (.swf ) to convert the document to a 
FlashPaper SWF file.

■ Select FlashPaper > Convert to PDF to convert the document to a PDF file.
■ Select FlashPaper > Email PDF to convert the document to a PDF file and e-mail it.

To select multiple worksheets to convert to a FlashPaper document:

1. In the Microsoft Excel document, do one of the following to select multiple worksheets:

■ Click the worksheet tab of the first document you want to select; then Control-click the 
tabs of other worksheets you want to select.

■ Right-click a worksheet tab and select Select All Sheets.
2. Do one of the following

■ Select FlashPaper > Convert to Macromedia Flash (.swf ) to convert the document to a 
FlashPaper SWF file

■ Select FlashPaper > Convert to PDF to convert the document to a PDF file.
■ Select FlashPaper > Email PDF to convert the document to a PDF file and e-mail it.
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Using the FlashPaper Options dialog box

You use the FlashPaper Options dialog box (FlashPaper > Options) in Microsoft Office 
applications to set specific document options. If you are creating a PDF file, you can also use the 
FlashPaper Options dialog box to set PDF security options. The FlashPaper Options dialog box 
includes a General tab and a PDF Security tab.

To use the General tab:

1. Select Include Outline if you want the document outline that appears in your Microsoft Office 
document to appear in your FlashPaper document. (For Excel documents, the outline includes 
the title of each spreadsheet tab.)

Note: This is the default selection.

2. Select View Results if you want FlashPaper to display the converted file in a browser 
immediately after conversion.

Note: This is the default selection.

3. If you are converting a Microsoft Excel document, do one of the following:

■ Select Convert Workbook to print all spreadsheets. (This is the default selection.)
■ Select Convert Active Sheet(s) to print only those worksheets you selected.

To use the PDF Security tab:

1. Select Require password to open the document if you want to require users to have a password 
to view the document. You can then set the password in the Password text box. The password 
you select is case sensitive, can contain both letters and numbers, and can be up to 32 characters 
in length.

2. Select Restrict permitted actions on open documents to restrict certain actions, and then do 
the following:

■ In the Password text box, type a password that gives users permission to perform restricted 
actions. The password you select is case sensitive, can contain both letters and numbers, and 
can be up to 32 characters in length.

■ Select Prevent printing to prevent users without the specified password from printing the 
document.

■ Select Prevent editing to prevent users without the specified password from editing the 
document.

■ Select Prevent selection of text and graphics to prevent users without the specified password 
from selecting text or graphics in the document.

■ Select Prevent changes to annotations or form fields to prevent users without the specified 
password from adding or editing annotations in the document.
Using the FlashPaper Options dialog box 17
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CHAPTER 4
Using FlashPaper with Other 

Macromedia Products
Macromedia FlashPaper 2 integrates with Macromedia Breeze, Macromedia Contribute, and 
Macromedia Flash, allowing you to use FlashPaper SWF files in all of these applications.

Using FlashPaper with Macromedia Breeze

Using FlashPaper with Macromedia Contribute

Using FlashPaper with Macromedia Flash

Using FlashPaper with Macromedia Breeze

Macromedia FlashPaper and Breeze integration makes it easy for Breeze presenters to share 
FlashPaper SWF files with Breeze participants. When a presenter loads a FlashPaper SWF file into 
the Breeze Content pod, the file becomes visible to all participants. The presenter can control the 
participants’ view of the FlashPaper SWF file by showing only certain portions of the document, 
selecting important text, or navigating pages.

You can add FlashPaper SWF files to your Breeze presentations by using the Select Content 
button or the Content pop-up menu.

To upload a FlashPaper SWF file to Breeze using the Select Content button:

1. Enter a Breeze meeting for which you are the presenter.

2. Select the Slides layout by clicking the Slides button at the lower left corner of the Breeze 
application window.

3. Click the Select Content button. If the Select Content button isn’t visible, click the plus sign in 
the lower left corner of the Content pod.

4. Select a FlashPaper SWF file from the File Upload dialog box and click Open.

The FlashPaper SWF file you selected is uploaded to Breeze and appears in the presentation 
window.
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To upload a FlashPaper SWF file to Breeze using the Content pop-up menu:

1. Enter a Breeze meeting for which you are the presenter.

2. Select the Slides layout by clicking the Slides button at the lower left corner of the Breeze 
application window.

3. Click the Content pop-up menu and select one of the following:

Select from Content Library to select a FlashPaper SWF file from the Content Library; 
then click Open.
Select from My Computer to select a FlashPaper SWF file from your computer; then 
click Open.
Select from Room Content to select a FlashPaper SWF file that has already been uploaded to 
the Breeze meeting.

The FlashPaper SWF file you selected appears in the presentation window.

Using FlashPaper with Macromedia Contribute

You can use the Insert menu in Contribute to convert a document to a FlashPaper SWF file, or 
you can drag a document to your Contribute draft and then insert the document as a FlashPaper 
SWF file. By embedding FlashPaper SWF files in your web pages, people can view files on your 
site without owning the software that created the original document, and without leaving the 
web page.

Creating and inserting FlashPaper SWF files

You can insert a FlashPaper SWF file into your Contribute draft by using the Insert menu, or by 
dragging a document to the draft.

To create and insert a FlashPaper SWF file using the Insert menu:

1. In the draft, place the insertion point where you want the FlashPaper SWF file to appear.

2. Select Insert > Document as FlashPaper.
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3. In the dialog box that appears, browse to the file you want to convert to a FlashPaper SWF file, 
and then click Open.

The FlashPaper Options dialog box appears.

4. Select the options you want to apply to the document you are inserting.

For more information about FlashPaper options, see “Using the FlashPaper Options dialog 
box”.

5. Click OK.

Contribute converts the document to a FlashPaper SWF file and inserts it into your draft.

To create and insert a FlashPaper SWF file by dragging:

1. In the draft, place the insertion point where you want the FlashPaper SWF file to appear.

2. Drag the document that you want to convert, and place it at the insertion point.

The Insert Microsoft Office Document dialog box appears
3. Select Insert the document as FlashPaper.

4. Click OK.

Contribute converts the document to a FlashPaper SWF file and inserts it into your draft.

To delete a FlashPaper SWF file from a draft:

1. In the draft, click the FlashPaper SWF file to select it.

2. Press Delete.
Using FlashPaper with Macromedia Contribute 21



Using the FlashPaper Options dialog box

You use the FlashPaper Options dialog box to define the page size and orientation of the 
FlashPaper SWF file you are inserting. You also determine whether or not to include Microsoft 
Office document outlines, if appropriate.

To use the FlashPaper Options dialog box:

1. For Page Orientation, select Portrait or Landscape.

2. For Page Size, do one of the following:

■ Select Standard, and then in the pop-up menu select a predefined paper size for the 
document. 

■ Select Custom to set specific width and height dimensions for the document pages. Use the 
pop-up menu to define the size in inches or millimeters (mm).

3. If you are converting a Microsoft Office document that includes an outline, and you want to 
include the outline in the FlashPaper SWF file, select Display document outline, if present.

4. Click OK.

Contribute converts the document to a FlashPaper SWF file and inserts it on the page.

Tip: You can choose Edit > Undo FlashPaper to remove the FlashPaper SWF file you just inserted.

Using FlashPaper with Macromedia Flash

You can insert a FlashPaper SWF file into a Flash FLA file. When you export the FLA file to 
SWF format, the FlashPaper SWF file is embedded as part of the exported Flash SWF file.

The following code shows how to load a FlashPaper SWF file in a regular FLA file using the 
loadFlashPaper() function:
function loadFlashPaper( 

path_s, // path of SWF to load 
dest_mc, // MC which we should replace with the SWF 
width_i, // new size of the dest MC 
height_i, // new size of the dest MC 
loaded_o) // optional: object to be notified that loading is complete

{ 
var intervalID = 0; 
var loadFunc = function() 
{ 

dest_mc._visible = false; 
var fp = dest_mc.getIFlashPaper(); 
if (!fp) 

return; 
if (fp.setSize(width_i, height_i) == false) 

return; 
dest_mc._visible = true; 
clearInterval(intervalID); 
loaded_o.onLoaded(fp); 

} 
intervalID = setInterval(loadFunc, 100); 
dest_mc.loadMovie(path_s);

}
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The following code shows how you can use the loadFlashPaper() function after you’ve 
embedded a FlashPaper SWF file:
function onLoaded(fp)
{

// loading is complete, so we can now adjust the current page, zoom, etc.
// go to page 50.
fp.setCurrentPage(50);
// change magnification to 33%
fp.setCurrentZoom(33);

}
loadFlashPaper("FlashPaper.swf", theDocMC, theDocMC._width, theDocMC._height, 

this);

The fp.setCurrentPage value has been set to 50 and the fp.setCurrentZoom value has been 
set to 33. When the FLA file is exported, page 50 of the embedded FlashPaper SWF file appears 
inside the exported SWF file with a magnification of 33 percent.
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